Search

GREAT RIDES & STAYS!
Fab Ads
Previous Thread
Next Thread
Print Thread
Rate Thread
No sound from horn #145960 09/06/19 10:11 PM
Joined: Apr 2018
Posts: 18
A
Aguaski Offline OP
Junior Member
OP Offline
Junior Member
A
Joined: Apr 2018
Posts: 18
I went for a ride with my son last night and noticed no sound was coming from my horn. I assumed the horn failed so this morning I replaced the XT225 horn with a known working nicer horn from one of my ATVís. Still no sound with the replacement horn. I opened up the handlebar switch where the horn button is and the connections looked solid, not even a spec of dust inside there. At that point the issue wasnít obvious and it was about 108 degrees outside so I put my tools back and walked away. Now I am I trying to troubleshoot from the comfort of my air conditioned house. Does the XT225 have a fuse for the horn? If yes, where is the horn fuse located? Any other ideas on what I should check?

Re: No sound from horn [Re: Aguaski] #145961 09/08/19 12:51 AM
Joined: Jun 2013
Posts: 3,467
peejman Offline
Platinum Member
*****
Offline
Platinum Member
*****
Joined: Jun 2013
Posts: 3,467
I don't think there's fuse in the horn circuit. Check continuity across the switch to see if the button is working. Check continuity of the wires between the button and the horn to see if you've got a bad wire.


This shall pass, be still and know.
2006 XT225, UNI filter, ProTaper bars, MSR handguards, SS front brake line, Shinko 241's.
Re: No sound from horn [Re: Aguaski] #145964 09/08/19 02:42 PM
Joined: Jan 2004
Posts: 6,023
Muniac Online Content
Platinum Member
*****
Online Content
Platinum Member
*****
Joined: Jan 2004
Posts: 6,023
Other than the main fuse, there is no fuse on the horn circuit. The DC that feeds the horn also feeds the turn signal indicator and all the turn signal lamps. Wire color is brown (+12) that feeds the horn. Return to ground from horn (through handlebar switch) is pink. From the switch to frame ground is black to complete the entire circuit.

I've had trouble with the handlebar switches both horn and starter. Your best bet is a VOM or test lamp to check for +12 down the circuit. One side of the horn should be "hot" when the bike is turned on (horn unplugged). I usually use a safety pin to check wires ahead of connections. If the horn and connections are good, the other side should be "hot" too when the horn is plugged in.

If you get these readings, shut the bike off and work from frame ground back up the circuit. Now using resistance or continuity, you should see a "closed" connection on black. Look for an open connection on pink until you press the horn switch. Sometimes a wire can break inside the insulation near a crimp connected terminal. The horn circuit has its own ground (black). Make sure it's good. You can go across pink and black to check just the handlebar switch. Or pink to frame ground to check the black ground wire and switch. That switch is normally open showing continuity when depressed.

Buzzing out these problems is just a systematic checking of each component, all related circuit wires, power and connections. The connections to the horn and the horn itself are exposed. I'd look there first.

The horns on both our bikes have failed. Dirt and water get in there and jams the diaphragm. Hope this helps and good luck!


Evolve & Simplify
Be There or Be Nowhere! A Few Adventures & Video

Web & Site Search
Google
 
Custom TO Customer
Specialty Resource
Fab Ads
Boardcaster Updates

Board Upgrade: Board upgrade to V7.7.3 has been completed on Monday Feb 3rd 2020. Ride safely. Enjoy the new software!

Who's Online Now
1 registered members (Muniac), 30 guests, and 1 spider.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Top Posters(All Time)
Reggie 11,645
Muniac 6,023
alexd 5,915
Moto Psycho 4,684
Az4x4 4,561
peejman 3,467
kris 2,366
Paul49 1,870
Doc250 1,643
JerryH 1,550
Forum Statistics
Forums38
Topics16,155
Posts144,819
Members5,481
Most Online279
Dec 6th, 2019
Newest Members
Mrs B-P, TribalHandyman, Backofthepackjac, Aaronmit, wamshitley
5481 Registered Users
July
S M T W T F S
1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30 31
Powered by UBB.threads™ PHP Forum Software 7.7.3